cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Observer
Observer
381 Views
Registered: ‎05-28-2020

Video Mixer not displaying solid background color

Jump to solution

While implementing the video mixer(v3.0) on PYNQ-Z1 board at vivado 2018.3, the solid background color is not displayed on the monitor after disabling the master layer. I have already reviewed the video mixer page guide(PG243) and forum link.
I have here included the picture of debug status of video mixer and SDK code of video mixer implementation. I have also implemented upon the Zybo Z7-10 board, but not seen background color either.Terminal Debug Message.png

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer
Observer
258 Views
Registered: ‎05-28-2020

I apologize for late reply. Thank you for providing the link. I reviewed the link you had provided but was not working.

Now, I have found the solution myself. It was having problem to set solid background color, because I gave direct resolution value for the output stream from the video mixer IP.
When I added the two programmable VTC IPs, in hardware design, for detection and generation of video timing signal. Then I set the output resolution value, in video mixer IP, according to detected incoming video resolution, then it worked.
Now I can see the background color when I disable the master layer. This problem is solved.

View solution in original post

2 Replies
Highlighted
Moderator
Moderator
284 Views
Registered: ‎11-21-2018

Hi @Nikhil_Thapa 

 

Have you also reviewed the video mixer tutorial on this? https://forums.xilinx.com/t5/Design-and-Debug-Techniques-Blog/Video-Series-32-Visualizing-the-Video-Mixer-example-design-using/ba-p/1026338

If you believe it is a bug, can you provide a test case that I can run?  

Aoife
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Highlighted
Observer
Observer
259 Views
Registered: ‎05-28-2020

I apologize for late reply. Thank you for providing the link. I reviewed the link you had provided but was not working.

Now, I have found the solution myself. It was having problem to set solid background color, because I gave direct resolution value for the output stream from the video mixer IP.
When I added the two programmable VTC IPs, in hardware design, for detection and generation of video timing signal. Then I set the output resolution value, in video mixer IP, according to detected incoming video resolution, then it worked.
Now I can see the background color when I disable the master layer. This problem is solved.

View solution in original post