cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
shuaibi
Visitor
Visitor
302 Views
Registered: ‎10-27-2020

hello,

i use zcu106 and petalinux 2020.1 build system.  in linux system,I run "gst-inspect-1.0"

then 

root@gundam:~# gst-inspect-1.0
rtspclientsink: rtspclientsink: RTSP RECORD client
coreelements: capsfilter: CapsFilter
coreelements: concat: Concat
coreelements: dataurisrc: data: URI source element
coreelements: downloadbuffer: DownloadBuffer
coreelements: fakesrc: Fake Source
coreelementsfakesink: Fake Sink
coreelements: fdsrc: Filedescriptor Source
coreelements: fdsink: Filedescriptor Sink
coreelements: filesrc: File Source
coreelements: funnel: Funnel pipe fitting
coreelements: identity: Identity
coreelements: input-selector: Input selectoz
coreelements[[0m: output-selector: Output selector
coreelements: queue: Queue
coreelements: queue2: Queue 2
coreelements: filesink: File Sink
coreelements: tee: Tee pipe fitting
coreelements: typefind: TypeFind
coreelements: multiqueue: MultiQueue
coreelements: valve: Valve element
coreelements: streamiddemux: Streamid Demux
omx: omxh264enc: OpenMAX H.264 Video Encoder
omx: omxh264dec: OpenMAX H.264 Video Decoder
omx: omxh265enc: OpenMAX H.265 Video Encoder
omx: omxh265dec: OpenMAX H.265 Video Decoder
coretracers: latency (GstTracerFactory)
coretracers: log (GstTracerFactory)
coretracers: rusage (GstTracerFactory)
coretracers: stats (GstTrace¹Tѽʥmm-)
coretracers: leaks (GstTracerFactory)
staticelements: bin: Generic bin
staticelements: pipeline: Pipeline object

total count: 5 plugins, 33 features

 

 

 this is zcu106 2020.1 bsp  default  configuration .  i  think plugin should have v4lsrc  so on.  

how to add v4lsrc.    

 

 

good day!

                                                                                                            lixiaolong

Tags (2)
0 Kudos
Reply
1 Solution

Accepted Solutions
watari
Teacher
Teacher
229 Views
Registered: ‎06-16-2013

Hi @shuaibi 

 

You need to add gst-plugins-base package.

Would you try it ?

 

https://github.com/Xilinx/gst-plugins-base

 

Best regards,

View solution in original post

2 Replies
watari
Teacher
Teacher
230 Views
Registered: ‎06-16-2013

Hi @shuaibi 

 

You need to add gst-plugins-base package.

Would you try it ?

 

https://github.com/Xilinx/gst-plugins-base

 

Best regards,

View solution in original post

shuaibi
Visitor
Visitor
219 Views
Registered: ‎10-27-2020

yes  petalinux  rootfs  i miss some package . thank you.

0 Kudos
Reply