UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor gourav_123
Visitor
409 Views
Registered: ‎01-31-2019

Can't synthesize TPG videosystem

Jump to solution

Hello ,

I m trying to implement TPG through zybo board for video streaming .I have installed TPG license.My design is validate correctly, but during synthesize it shown error that i listed below that.

  • [Synth 8-439] module 'design_1_v_tpg_0_0_v_tpg' not found 
  • [Synth 8-285] failed synthesizing module 'design_1_v_tpg_0_0' 
  • [Synth 8-285] failed synthesizing module 'design_1' .

I have checked previous thread on xilinx form

https://forums.xilinx.com/t5/Video/Can-t-synthesize-with-Video-Test-Pattern-Generator-even-with/td-p/683222

Still dosent get any idea how to resolve this.Pls provide some suggestions for that query

Thanks in advacne. 

 

 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
363 Views
Registered: ‎11-09-2015

Re: Can't synthesize TPG videosystem

Jump to solution

Hi @gourav_123,

Can you check the vivado_hls.log file created into the TPG IP output products (project.runs/synth_1/...tpg...) it should contain the error.

Possible reasons:

  1. You are under windows and the path is >256 characters
  2. You have an unexpected character in the project path (refer to AR#71759)
  3. Your license is not picked correctly

Also if you check the following post, Tim solved his issue by closing and re-openeing vivado:

https://forums.xilinx.com/t5/Video/VTPG-Synth-8-439-Module-not-found/m-p/884702

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
1 Reply
Moderator
Moderator
364 Views
Registered: ‎11-09-2015

Re: Can't synthesize TPG videosystem

Jump to solution

Hi @gourav_123,

Can you check the vivado_hls.log file created into the TPG IP output products (project.runs/synth_1/...tpg...) it should contain the error.

Possible reasons:

  1. You are under windows and the path is >256 characters
  2. You have an unexpected character in the project path (refer to AR#71759)
  3. Your license is not picked correctly

Also if you check the following post, Tim solved his issue by closing and re-openeing vivado:

https://forums.xilinx.com/t5/Video/VTPG-Synth-8-439-Module-not-found/m-p/884702

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos