UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie svenkat2
Newbie
472 Views
Registered: ‎01-09-2019

No output on display - Tricube application

Hi, We are trying to run the tricube applicatiion by following this tutorial :https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_4/ug1209-embedded-design-tutorial.pdf on ultrazed EG with the carrier board.

While building it is throwing assertion failed errors (Please refer the log file attached). We can run the application but there is no output on the display.

 

NOTE : The following command:  /usr/bin/Xorg -depth 16& is changed to /usr/bin/Xorg -depth 24& since we are using DELL monitor.

0 Kudos
7 Replies
Moderator
Moderator
431 Views
Registered: ‎11-09-2015

Re: No output on display - Tricube application

HI @svenkat2,

Are you using a Displayport monitor (i.e. no DP to HDMI/VGA/DVI adapter)? If not please use a DP monitor.

If you do not have one, please make sure you are using an active adapter. Passive adapters are not supported by the DP controller.

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
Newbie svenkat2
Newbie
350 Views
Registered: ‎01-09-2019

Re: No output on display - Tricube application

Hi 

0 Kudos
Moderator
Moderator
332 Views
Registered: ‎11-09-2015

Re: No output on display - Tricube application

Hi @svenkat2,

What vivado/SDK/petalinux version are you using? Did you try with 2018.3

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Newbie svenkat2
Newbie
313 Views
Registered: ‎01-09-2019

Re: No output on display - Tricube application

Hi  

I am using vivado/SDK/petalinux version 2018.2

0 Kudos
Moderator
Moderator
233 Views
Registered: ‎11-09-2015

Re: No output on display - Tricube application

HI @svenkat2,

Did you try with any pre-built images for the ultrazed board? Are you able to get any output on the DP monitor at all?

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Newbie svenkat2
Newbie
125 Views
Registered: ‎01-09-2019

Re: No output on display - Tricube application

Yes, But it is loading from emmc flash instead of memory card even though the dip switches are in correct position.

0 Kudos
Highlighted
Moderator
Moderator
82 Views
Registered: ‎11-09-2015

Re: No output on display - Tricube application

Hi @svenkat2,

How do you know that it it is loading from the flash instead of the SD card?

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos