UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor toni_birka
Visitor
316 Views
Registered: ‎03-07-2019

Running VTC self test freezes on ZYBO

Jump to solution

Hello,

My application freezes after I run the self-test for a video timing controller. What is the cause of the problem? 

The used Block design is shown below and project files are available on the following link: https://www.dropbox.com/s/tjd21flsmxn650i/ZYNN_project.rar?dl=0

Best regards,

ToniCapture.JPG.7053c7ca22ea20e9e9dab194d74d6025.JPG

0 Kudos
1 Solution

Accepted Solutions
Visitor toni_birka
Visitor
119 Views
Registered: ‎03-07-2019

Re: Running VTC self test freezes on ZYBO

Jump to solution
Never mind, I've found what was the problem. I named external port HDP instead of HPD, but haven't noticed it before in critical warnings.

Best regards,
Toni
10 Replies
Moderator
Moderator
267 Views
Registered: ‎11-09-2015

Re: Running VTC self test freezes on ZYBO

Jump to solution

Hi @toni_birka ,

Do you have the HDMI connected? I believe you need to have an active HDMI clock else the VTC will return a slave error on the AXI4-Lite interface:

slave error.JPG

So any access to the IP will report an error. This is probably what you are experiencing


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Moderator
Moderator
235 Views
Registered: ‎11-09-2015

Re: Running VTC self test freezes on ZYBO

Jump to solution

Hi @toni_birka ,

Do you have any update on this? Did my reply helped you?

If your question is answered or your issue is solved, please kindly mark the response which helped as solution (click on "Accept as solution" button below the reply)

If this is not solved/answered, please reply in the topic giving more information on your current status.

Thanks and Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Visitor toni_birka
Visitor
219 Views
Registered: ‎03-07-2019

Re: Running VTC self test freezes on ZYBO

Jump to solution

Hello,

sorry for the late response. I’m pretty sure that it has active clock, because i have connected GoPro camera on HDMI input.

Best regards,

Toni

0 Kudos
Moderator
Moderator
206 Views
Registered: ‎11-09-2015

Re: Running VTC self test freezes on ZYBO

Jump to solution

Hi @toni_birka ,

You migth want to make sure the clock is here. I would recommend to do some logic to toggle a LED to make sure you have the clock.


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Visitor toni_birka
Visitor
190 Views
Registered: ‎03-07-2019

Re: Running VTC self test freezes on ZYBO

Jump to solution
Hi @florentw,
Can you tell me where should I connect an LED? I mean on which pin is that clock available?

Best regards,
Toni
0 Kudos
Moderator
Moderator
187 Views
Registered: ‎11-09-2015

Re: Running VTC self test freezes on ZYBO

Jump to solution

Hi @toni_birka ,

Check the xdc file or user guide for the zybo to find a led you can use. And the clock is the one connected to the clk input of the vtc


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Visitor toni_birka
Visitor
148 Views
Registered: ‎03-07-2019

Re: Running VTC self test freezes on ZYBO

Jump to solution

Hi @florentw,

I connected the LED to the Pixel clock which is input to the vtc, and edited the .xdc file, but when I tested it LED didn't work. I use GoPro camera as the HDMI source, and it's working when I connect it to the TV via HDMI. What should I do to fix it?

Best regards,
Toni

Capture.JPG
0 Kudos
Moderator
Moderator
144 Views
Registered: ‎11-09-2015

Re: Running VTC self test freezes on ZYBO

Jump to solution

Hi @toni_birka ,

Well you need to have the gopro working...

What could happen is that the Gopro does not support DVI over HDMI. This might be why you are not getting the clock.

So either change your source or use a HDMI RX solution (true HDMI not DVI over HDMI).


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Visitor toni_birka
Visitor
135 Views
Registered: ‎03-07-2019

Re: Running VTC self test freezes on ZYBO

Jump to solution
Hi @florentw,
well, I was using GoPro as a source when I was testing the hdmi_in example and it contains the DVI2RGB IP and it worked. As well, I'm using the same block design as Adam Taylor in his project(https://www.hackster.io/adam-taylor/creating-a-zynq-or-fpga-based-image-processing-platform-e79394), and he used an action camera similar to GoPro as a source.
Do you have any details/links/references for that solution, where I can find more information about implementation?

Best regards,
Toni
0 Kudos
Visitor toni_birka
Visitor
120 Views
Registered: ‎03-07-2019

Re: Running VTC self test freezes on ZYBO

Jump to solution
Never mind, I've found what was the problem. I named external port HDP instead of HPD, but haven't noticed it before in critical warnings.

Best regards,
Toni