UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer rishubnagpal
Observer
854 Views
Registered: ‎04-19-2018

Video Test Patter Generator not producing data

Jump to solution

I've been trying to understand how to use the AXI4-Stream to Video Out IP but can't seem to get anything on the screen. Here is my test circuit: 

 

circuit

 

I have included the TCL file for this design below

 

I have a Video Test Pattern Generator connected to an Axi4-stream to Video Out IP driven by a Video Timing Controller IP. The Axi4s to video out is driven by a 25Mhz clock and the VTC and VTPG are driven by a 50 Mhz clock (is this correct?) 

 

Here is a simulation: 

sim

 

As you can see, Tdata ( from the VTPG ) produces only X's. TVALID is never set. The lock signal is never produced as well. Any ideas on why this is happening? My target board is the Nexys 4 DDR. Here are the settings for my IPs:

 

Any guidance would be appreciated! 

 

ip1

 

ip2

 

ip3

 

ip4

ip5

 

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,170 Views
Registered: ‎11-09-2015

Re: Video Test Patter Generator not producing data

Jump to solution

Hi @rishubnagpal,

 

You might want to read the Product Guide for the TPG (PG103) before using it.

 

You are not controlling the AXI-Lite interface. The TPG IP requires to be started by configuring reg 0x0:

TPG.JPG

 

You can have an example of simulation with the TPG using the Example design for the TPG. Refer to PG103 chapter 6 (Simulation example design).

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
3 Replies
Moderator
Moderator
1,171 Views
Registered: ‎11-09-2015

Re: Video Test Patter Generator not producing data

Jump to solution

Hi @rishubnagpal,

 

You might want to read the Product Guide for the TPG (PG103) before using it.

 

You are not controlling the AXI-Lite interface. The TPG IP requires to be started by configuring reg 0x0:

TPG.JPG

 

You can have an example of simulation with the TPG using the Example design for the TPG. Refer to PG103 chapter 6 (Simulation example design).

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
Observer rishubnagpal
Observer
802 Views
Registered: ‎04-19-2018

Re: Video Test Patter Generator not producing data

Jump to solution

@florentw Thanks for the quick reply.

 

Does this mean I will need a MicroBlaze processor? 

0 Kudos
Highlighted
Moderator
Moderator
795 Views
Registered: ‎11-09-2015

Re: Video Test Patter Generator not producing data

Jump to solution

Hi @rishubnagpal,

 

Does this mean I will need a MicroBlaze processor? 

> For simulation you can use only a VIP as in the simulation reference design.

For running on HW, the recommended (and simplest ) flow is to use a Microblaze but if you want you can only create an customer IP to do the AXI4-Lite write to registers.

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos