UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor fengye0321
Visitor
7,600 Views
Registered: ‎03-12-2015

inaccurate text display on OSD

I'm using zynq-7000 and adding a OSD 6.0 IP in my project. There are two layers: one is video layer, the other is GC layer. Both are 1920 x 1080. The video output itself looks fine, just the text outputs are inaccurate as the appendix show.

What's the possible cause of this problem?

1.bmp
0 Kudos
5 Replies
Xilinx Employee
Xilinx Employee
7,450 Views
Registered: ‎02-06-2013

Re: inaccurate text display on OSD

Hi

 

Did you check the debugging section of pg019 and what is the inaccuracy you are pointing in the attachment?

Regards,

Satish

--------------------------------------------------​--------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful.
--------------------------------------------------​-------------------------------------------
0 Kudos
Visitor fengye0321
Visitor
7,422 Views
Registered: ‎03-12-2015

Re: inaccurate text display on OSD

Thank you for your reply.

If you enlarge the image, you will find the edge of text is not in order.

 

image.png
0 Kudos
Visitor benvario
Visitor
7,034 Views
Registered: ‎08-19-2015

Re: inaccurate text display on OSD

Hello,

 

I have exactly the same problem. Does someone has the solution to this problem?

Thanks for your support.

 

Br,

Ben

0 Kudos
Explorer
Explorer
545 Views
Registered: ‎05-30-2017

Re: inaccurate text display on OSD

Hi @fengye0321,

did you solve your problem? Maybe this can be usefull.

https://forums.xilinx.com/t5/Video/Video-On-Screen-Display-OSD-IP-shift-text-to-left-when/m-p/876354#M21157

I'm working with vivado 2018.2 and IP OSD version 6. I can draw boxes but I can't write text. I don't understand my mistake but I think that IP OSD is buggy. You configured OSD using API or directly writing in the registers? Have you a working design with OSD that you could share? Thank you. 

0 Kudos
Visitor danieltang
Visitor
125 Views
Registered: ‎08-11-2018

Re: inaccurate text display on OSD

hello ,I'm working with vivado 2017.4 and IP OSD version 6. Could you a working design with OSD that you could share,like draw a box or text? Thank you.
0 Kudos