Showing results for 
Show  only  | Search instead for 
Did you mean: 
Registered: ‎02-25-2009

Problem with ethernet in ml410 board

1. Anybody success in using ethernet with xps_ll_temac (EDK 10.1, hw driver version 1.01a)? I can't get it work in either MII mode or RGMII mode. (GMII mode is not supported, right?) Even build a system with bsb using MII, an web_server application (adopted from Avnet's reference design) simply fails - can't ping the board ip. Building a system with bsb using XPS_ethernet also fails a ping program. Neither tx or rx led is blinking.


I try to modify core xps_ll_temac in RGMII mode, copying constraints from 2.00a's datasheet. I can't pass timing constrains on RX data of 1ns setup and hold time. However, according to HP's RGMII spec, the normal value for setup and hold time is more than 1ns. I relax the timing constrain and got passed. While tx led is blinking, rx led is dead.


Is there any problem with hardware ip? The hardware seems to be OK since the "rgmii" reference design on Xilinx's ml410 page works. (But the hw drive is plb_temac with a hard core wrapper).


2. I'm poring a linux to ml410. Anybody is able go use NFS? I'm git latest linux-2.6-Xilinx kernel from xilinx.linux. Obviously, I can not use LL_TEMAC drive, as I said above, I can't get MII or RGMII mode work with a xps_ll_temac core. It seems the only drive I can use is the plb_temac. However, the drive there can't get compiled.


I tried to use EDK's BSP generator to generate an alternative drive, copying it to $linux_kernel_dir/drive/net/xilix_temac, however, I still can't get the code compiled. I tried different EDK's linux 2.6 kernel libray versions, without any luck ...


Any suggetion is highly appreciated. (for the time being, it seems that my only option is to use a CF card for root FS ...)

Tags (2)
0 Kudos
0 Replies