cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
166 Views
Registered: ‎10-14-2019

How to use C++ 17 standard in Vitis?

Jump to solution

I got an error:

structured bindings only available with '-std=c++17' or '-std=gnu++17'	

But I don't know where to pass this option to compiler.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
96 Views
Registered: ‎11-04-2010

For the way to add option for g++ in command line and GUI, you can refer to the snapshots. But I doubt whether C++17 std is supported in 20.1.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

xrt1.png
xrt2.png
0 Kudos
2 Replies
Highlighted
Moderator
Moderator
97 Views
Registered: ‎11-04-2010

For the way to add option for g++ in command line and GUI, you can refer to the snapshots. But I doubt whether C++17 std is supported in 20.1.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

xrt1.png
xrt2.png
0 Kudos
Highlighted
Visitor
Visitor
51 Views
Registered: ‎10-14-2019

Thank you. When I right click project name_system and choose C/C++ build settings, there is also a "Tool settings" and I pass "-std=c++2a" in "system bulider". It amazingly works. 

0 Kudos