cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
bg_viv
Observer
Observer
461 Views
Registered: ‎05-19-2021

Vitis 2020.2 - fatal error: xparameters.h: No such file or directory

Jump to solution

Hello,

I am working on a project in Vitis 2020.2 and I am having an error when attempting to build my application project. I have set up the application project with an include folder inside of it where my files to include are; however, I want to also include the files that are in my platform project bsp. To do this I went to project > properties > C/C++ General > Paths and Symbols, and then added the file path to the platform project and its includes: platform_project/psu_cortexr5_0/psu_cortexr5_0/bsp/psu_cortexr5_0/include

In addition to that I put that path under project > properties > C/C++ Build > Settings > Tool Settings > gcc compiler > Directories

Unfortunately when I try to clean and build my project I get the error: fatal error: xparameters.h: No such file or directory. As well as a second error saying that one of the .h files in my project include directory is not found (but the file is present in the directory, I am not as concerned about this issue as the xparameters.h issue at the moment).

I can fix this error by importing the xparameters.h file into my project's include directory; however, this then generates a new error saying another one of the platform project bsp include files does not exist, and it is unreasonable to copy all the files into my includes directory, there must be a way to set a path correctly for includes.

Has anyone experienced an issue similar to this, or does anyone know the correct process for setting up a pointer for include files? Thank you in advance.

0 Kudos
1 Solution

Accepted Solutions
bg_viv
Observer
Observer
353 Views
Registered: ‎05-19-2021

The issue has been solved. The issue was in the bsp settings, not all of the supported libraries needed were selected, in the settings I went in and checked the boxes with the required libraries that contained the .h files that were not found and then after cleaning and building the projects this removed the issue I was having. 

View solution in original post

0 Kudos
2 Replies
gmarinkovic
Explorer
Explorer
419 Views
Registered: ‎01-09-2012

@bg_viv 

 

Does your BSP compile properly? I had cases when my BSP was having problems and then the xparameter.h was not complete, missing or had other problems.

 

Cheers

Goran

0 Kudos
bg_viv
Observer
Observer
354 Views
Registered: ‎05-19-2021

The issue has been solved. The issue was in the bsp settings, not all of the supported libraries needed were selected, in the settings I went in and checked the boxes with the required libraries that contained the .h files that were not found and then after cleaning and building the projects this removed the issue I was having. 

View solution in original post

0 Kudos