cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
joseer
Voyager
Voyager
865 Views
Registered: ‎07-06-2016

Vitis 2020.2 recipe for target 'package' failed

Jump to solution

Hello,

 

I followed this tutorial series but for 2020.2 and when I reach the point where I have to build the example vector application in software emulation mode, I've got the next error:

 

Section: 'BITSTREAM'(0) was successfully written.
Format: RAW
File  : '~/dev/hdl/VitisWorkspaces/Acceleration/first_accel_system/Emulation-HW/package.build/package/behav.xse'
WARNING: [v++ 82-1148] Skipping boot image generation since FSBL is directly loaded onto emulator
terminate called after throwing an instance of 'std::out_of_range'
  what():  basic_string::at: __n (which is 0) >= this->size() (which is 0)
~/opt/Xilinx/Vitis/2020.2/bin/loader: line 309: 14319 Aborted                 (core dumped) "$RDI_PROG" "$@"
makefile:38: recipe for target 'package' failed
make: *** [package] Error 134

 

 

And vitis gets stuck at 88% of build I have to kill the process to close it.

The problem is that there's not more information about the error, 

does anyone  have an idea what this error means?

Thanks in advance.

0 Kudos
1 Solution

Accepted Solutions
yangc
Xilinx Employee
Xilinx Employee
774 Views
Registered: ‎02-27-2019

If you can run it successfully with the official platform, that means the software environment is correct. Then we may focus on your custom platform.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
7 Replies
yangc
Xilinx Employee
Xilinx Employee
794 Views
Registered: ‎02-27-2019

What size of memory with your machine? With the official platform, does the error occur?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
joseer
Voyager
Voyager
787 Views
Registered: ‎07-06-2016

Hi @yangc , thanks for your reply,

the machine got 16GB of memory, and sorry, what do you mean with the official platform?

0 Kudos
yangc
Xilinx Employee
Xilinx Employee
779 Views
Registered: ‎02-27-2019

From the link, it seems to create the custom platform.

https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/embedded-platforms.html See it for the official platform.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
joseer
Voyager
Voyager
777 Views
Registered: ‎07-06-2016

Ok thanks for the link, but the base platforms seem to be targeting dev boards, so in my case I'm using a custom zynqMP hardware board, which one would I need to download?  

0 Kudos
yangc
Xilinx Employee
Xilinx Employee
775 Views
Registered: ‎02-27-2019

If you can run it successfully with the official platform, that means the software environment is correct. Then we may focus on your custom platform.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
joseer
Voyager
Voyager
765 Views
Registered: ‎07-06-2016

Ok, I'll do like suggested,  I'll build the example in vitis using one of the platforms and I'll get back with the results, thanks.

0 Kudos
joseer
Voyager
Voyager
717 Views
Registered: ‎07-06-2016

I've tried the zcu104 official platform and it did work fine, so I decided to start from scratch with the custom platform and it did work, now the application system builds fine.

Thanks.

0 Kudos