cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
joancab
Mentor
Mentor
322 Views
Registered: ‎05-11-2015

Vitis ignores saving to a specific location

Jump to solution

Vitis 2019.2, create a platform project, untick the 'Use default location' box and typing another path does not work, it saves it in the specified workspace

joancab_0-1610025380867.png

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
kmorris
Xilinx Employee
Xilinx Employee
255 Views
Registered: ‎01-11-2011

Hello @joancab, I am able to see the same behavior in the GUI in which it doesn't change the location of the project outside of the workspace. In looking into this, the GUI utilizes XSCT commands under the hood, and specifically the 'platform create' command. This command defaults all projects to be created inside of the workspace when a workspace is defined, so in a GUI setting, this would always be set.

In order to manually specify another location, the command line would need to be used. This command is documented for 2019.2 here. In 2020.2 and later versions, this option is no longer given to avoid confusion relating to the workspaces.

-------------------------------------------------------------------------
Please don’t forget to reply, kudo, and accept as solution!
-------------------------------------------------------------------------

View solution in original post

1 Reply
kmorris
Xilinx Employee
Xilinx Employee
256 Views
Registered: ‎01-11-2011

Hello @joancab, I am able to see the same behavior in the GUI in which it doesn't change the location of the project outside of the workspace. In looking into this, the GUI utilizes XSCT commands under the hood, and specifically the 'platform create' command. This command defaults all projects to be created inside of the workspace when a workspace is defined, so in a GUI setting, this would always be set.

In order to manually specify another location, the command line would need to be used. This command is documented for 2019.2 here. In 2020.2 and later versions, this option is no longer given to avoid confusion relating to the workspaces.

-------------------------------------------------------------------------
Please don’t forget to reply, kudo, and accept as solution!
-------------------------------------------------------------------------

View solution in original post