cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
brandon.cerge
Visitor
Visitor
2,749 Views
Registered: ‎11-18-2019

Vitis not creating platform from custom XSA File

Jump to solution

I've got a custom Artix7 Board running a microblaze architecutre that I am trying to get imported into Vitis. 

When i try and load my XSA into the Platform Project, I just get blank options for the OS and the Processor, almost like the XSA file Vivado is creating is no good : 

error1.pngerror2.png 

I've also tried just loading my XSA file directly into a blank Application Software Project, but Vitis bugs out on me : 

error3.PNG

 

Anybody point me in the right direction? 

1 Solution

Accepted Solutions
brandon.cerge
Visitor
Visitor
2,704 Views
Registered: ‎11-18-2019

After messing with this more, I've figure out the issue. Vitis will only create the platform if the workspace is inside the vivado project dicretory. I made a [project_name].vitis folder, and set that as my workspace, and it worked. This is simular to the old .sdk folder that would get created. 

View solution in original post

3 Replies
brandon.cerge
Visitor
Visitor
2,705 Views
Registered: ‎11-18-2019

After messing with this more, I've figure out the issue. Vitis will only create the platform if the workspace is inside the vivado project dicretory. I made a [project_name].vitis folder, and set that as my workspace, and it worked. This is simular to the old .sdk folder that would get created. 

View solution in original post

byliu
Newbie
Newbie
1,847 Views
Registered: ‎08-19-2020

I have similar problem. I think the solution might be your linux failed to provide xlsclients binary. (Are you using linux btw?) If you install xlsclients or xorg-xlsclients, it might works as usual.

kisonhe
Newbie
Newbie
534 Views
Registered: ‎04-22-2021

Thanks, you really saved my day.

0 Kudos