UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
197 Views
Registered: ‎09-17-2018

Zynq embedded acceleration - "XILINX_XRT must be set"

Jump to solution

Hello,

I'm trying to make Vitis hw-accelerated project. I have managed to build and compile simple vector addition program from samples but after copying files it seems that I can't run program.

How can I fix this error? Can you tell me or/and provide links?

I have copied new generated "rootfs", image.ub, BOOT.BIN, and system.dtb (screenshots) and when trying to run script from home I'm getting that error.

Screenshot from 2020-01-26 14-13-32.png

Screenshot from 2020-01-26 14-22-03.pngScreenshot from 2020-01-26 14-22-28.pngScreenshot from 2020-01-26 14-23-30.png

Thanks for help!

Screenshot from 2020-01-26 14-13-32.png
Screenshot from 2020-01-26 14-22-03.png
Screenshot from 2020-01-26 14-22-28.png
Screenshot from 2020-01-26 14-23-30.png
0 Kudos
1 Solution

Accepted Solutions
Observer derekhorng
Observer
122 Views
Registered: ‎03-26-2019

Re: Zynq embedded acceleration - "XILINX_XRT must be set"

Jump to solution

try this 

export XILINX_XRT=/usr

 

 

View solution in original post

3 Replies
Observer derekhorng
Observer
123 Views
Registered: ‎03-26-2019

Re: Zynq embedded acceleration - "XILINX_XRT must be set"

Jump to solution

try this 

export XILINX_XRT=/usr

 

 

View solution in original post

Contributor
Contributor
92 Views
Registered: ‎09-17-2018

Re: Zynq embedded acceleration - "XILINX_XRT must be set"

Jump to solution

Thanks! it semi-worked now Im stuck at another error...

Do you know why it says that there is no devices?Screenshot from 2020-02-11 01-35-16.png

0 Kudos
Contributor
Contributor
56 Views
Registered: ‎09-17-2018

Re: Zynq embedded acceleration - "XILINX_XRT must be set"

Jump to solution
0 Kudos