UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor yunzhehi
Visitor
1,275 Views
Registered: ‎07-18-2018

sdx2017.4 XOCC kernel compiler cannot set --kernel_frequency?

Jump to solution

HI,

   when I use sdx2017.2, I can set the XOCC kernel compiler frequency with "--kernel_frequency=200" to change the default frequency.

   now use the sdx2017.4, it seems the "--kernel_frequency=200" just ignored in the compiler.

   is it a bug? or sdx2017.4 has other methods to set kernel frequency?

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,227 Views
Registered: ‎11-04-2010

Re: sdx2017.4 XOCC kernel compiler cannot set --kernel_frequency?

Jump to solution

Hi, @yunzhehi ,

It's an issue in Sdx 2017.4, which has been fixed in Sdx 2018.2.

 

To workaround the issue, you can set period in a tcl file and execute it before hls:

TCL content:  create_clock -period <kernel_frequency>Hz -name default

option: --xp prop:solution.hls_pre_tcl=hls_hook.tcl

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

6 Replies
Moderator
Moderator
1,264 Views
Registered: ‎11-04-2010

Re: sdx2017.4 XOCC kernel compiler cannot set --kernel_frequency?

Jump to solution
Please refer to the below discussion:
https://forums.xilinx.com/t5/SDAccel/2017-4-Sdaccel-Ubuntu16-03-XOCC-Options-kernel-frequency-problem/m-p/823160#M1664
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor yunzhehi
Visitor
1,259 Views
Registered: ‎07-18-2018

Re: sdx2017.4 XOCC kernel compiler cannot set --kernel_frequency?

Jump to solution

I viewed the discussion, but seems not the same problem.

I tried to change frequency in compiler not linker, I want to change default frequency in HLS result, not SYN/PLACE/ROUTER.

do you have any suggestion?

0 Kudos
Moderator
Moderator
1,238 Views
Registered: ‎11-04-2010

Re: sdx2017.4 XOCC kernel compiler cannot set --kernel_frequency?

Jump to solution

The option you use is "--kernel_frequency=200"

Have you tried:  "--kernel_frequency 200"

 

 

 

 

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor yunzhehi
Visitor
1,233 Views
Registered: ‎07-18-2018

Re: sdx2017.4 XOCC kernel compiler cannot set --kernel_frequency?

Jump to solution

"--kernel_frequency 200" does not working too. It seems the compiler just ignore --kernel_frequency

 

hls.png

0 Kudos
Moderator
Moderator
1,228 Views
Registered: ‎11-04-2010

Re: sdx2017.4 XOCC kernel compiler cannot set --kernel_frequency?

Jump to solution

Hi, @yunzhehi ,

It's an issue in Sdx 2017.4, which has been fixed in Sdx 2018.2.

 

To workaround the issue, you can set period in a tcl file and execute it before hls:

TCL content:  create_clock -period <kernel_frequency>Hz -name default

option: --xp prop:solution.hls_pre_tcl=hls_hook.tcl

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

Visitor yunzhehi
Visitor
1,223 Views
Registered: ‎07-18-2018

Re: sdx2017.4 XOCC kernel compiler cannot set --kernel_frequency?

Jump to solution

yeah,it's working, thank you.

0 Kudos