UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie erickcb
Newbie
741 Views
Registered: ‎02-13-2018

Launch_run and wait_for_run in Vivado HLS

Hi,

Is there an equivalent to launch_run and wait_for_run for Vivado HLS?

My TCL script seems to continue before the csynth is completely done.

Thanks in advance
Tags (3)
0 Kudos
4 Replies
Scholar hbucher
Scholar
726 Views
Registered: ‎03-22-2016

Re: Launch_run and wait_for_run in Vivado HLS

@erickcb Aren't you misspelling the commands? I see launch_runs and wait_on_run.

Perhaps it is hitting a syntax error and keeping going

 

vitorian.com --- We do this for fun. Always give kudos. Accept as solution if your question was answered.
I will not answer to personal messages - use the forums instead.
wait_on_run.png
0 Kudos
Newbie erickcb
Newbie
717 Views
Registered: ‎02-13-2018

Re: Launch_run and wait_for_run in Vivado HLS

Those work fine on Vivado, but they don't work on Vivado HLS
0 Kudos
Scholar hbucher
Scholar
666 Views
Registered: ‎03-22-2016

Re: Launch_run and wait_for_run in Vivado HLS

@erickcb Just tested - csynth_design blocks until completion in a tcl script.

vitorian.com --- We do this for fun. Always give kudos. Accept as solution if your question was answered.
I will not answer to personal messages - use the forums instead.
0 Kudos
Highlighted
Newbie erickcb
Newbie
644 Views
Registered: ‎02-13-2018

Re: Launch_run and wait_for_run in Vivado HLS

You are right, although for some reason when I used a TCL command to delete a directory, it appeared as if it was not waiting. After removing that command looks like everything is fine. Thanks!

0 Kudos