UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

Launch_run and wait_for_run in Vivado HLS

Newbie
Posts: 3
Registered: ‎02-13-2018

Launch_run and wait_for_run in Vivado HLS

Hi,

Is there an equivalent to launch_run and wait_for_run for Vivado HLS?

My TCL script seems to continue before the csynth is completely done.

Thanks in advance
Scholar
Posts: 1,869
Registered: ‎03-22-2016

Re: Launch_run and wait_for_run in Vivado HLS

@erickcb Aren't you misspelling the commands? I see launch_runs and wait_on_run.

Perhaps it is hitting a syntax error and keeping going

 

vitorian.com --- We do this for fun. Always give kudos. Accept as solution if your question was answered.
I will not answer to personal messages - use the forums instead.
wait_on_run.png
Newbie
Posts: 3
Registered: ‎02-13-2018

Re: Launch_run and wait_for_run in Vivado HLS

Those work fine on Vivado, but they don't work on Vivado HLS
Scholar
Posts: 1,869
Registered: ‎03-22-2016

Re: Launch_run and wait_for_run in Vivado HLS

@erickcb Just tested - csynth_design blocks until completion in a tcl script.

vitorian.com --- We do this for fun. Always give kudos. Accept as solution if your question was answered.
I will not answer to personal messages - use the forums instead.
Highlighted
Newbie
Posts: 3
Registered: ‎02-13-2018

Re: Launch_run and wait_for_run in Vivado HLS

You are right, although for some reason when I used a TCL command to delete a directory, it appeared as if it was not waiting. After removing that command looks like everything is fine. Thanks!