UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
2,038 Views
Registered: ‎12-08-2016

confusion with Resource Utilization

Hi Folks,

 

I am doing with Vivado HLS IP design, after synthesis design resource utilization shows BRAM is 99%.

 

I've vivado integrator design (without HLS IP Block) after bitstream generation resource utilization report is shows BRAM is 4%,

 

I added HLS IP into Vivado integrator design and i run the synthesis and generates the Bitstream.

 

i checked resource utilization report is shows BRAM is 36%.

 

how come suddenly the BRAM utilization Became 36% though HLS IP taking 99% BRAM. 

I confused with this utilization report.

Is anyone what is the reason or any idea for the above subject, please give me valuable suggestions.

 

Thanks and Best Regards

Vinod Sajjan 

 

 

0 Kudos
2 Replies
Mentor xilinxacct
Mentor
228 Views
Registered: ‎10-23-2018

Re: confusion with Resource Utilization

@vinodsajjan

If the 'part' you are targeting the same within HLS and Vivado?

Is there a 'unconnected' BRAM that is counted in HLS, and optimized out in Vivado?

Hope that helps

Please mark as solution accepted to close the issue. Kudos also welcomed :-)

 

Highlighted
Moderator
Moderator
187 Views
Registered: ‎05-31-2017

Re: confusion with Resource Utilization

HI @vinodsajjan,

Did you check the utilization after exporting the RTL as IP with synthesis, place and route options as these will give the exact utilization values whereas synthesis option in HLS converts the c/c++ language into HDL giving just utilization estimates but not the exact utilization.

0 Kudos