cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jeremy.roy
Visitor
Visitor
4,572 Views
Registered: ‎11-02-2016

Bug report: Vivado 2016.2 start_gui

Jump to solution

Hey there, I've noticed that whenever I run a tcl procedure from the Vivado GUI that runs "stop_gui" followed by "start_gui", the Vivado GUI does not respond after the next action is taken.

 

Ex:

proc freeze_vivado {} {
<some_code> stop_gui
update_compile_order -fileset sources_1
synth_design start_gui }

When the GUI starts I can navigate through the design, but as soon as I try to perform an action that generates a tcl command Vivado stops responding.

0 Kudos
1 Solution

Accepted Solutions
nupurs
Moderator
Moderator
7,966 Views
Registered: ‎06-24-2015

@jeremy.roy,

 

Can you run update_compile_order with the -force_gui option?

Refer page 1494 of this link for details: https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_3/ug835-vivado-tcl-commands.pdf

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).

View solution in original post

4 Replies
vijayak
Xilinx Employee
Xilinx Employee
4,513 Views
Registered: ‎10-24-2013

Hi @jeremy.roy

 

Can you please try using 2016.3? If you are able to reproduce the issue with 2016.3 please attach the sample testcase with which we can reproduce the issue at our end. Which OS are you using?

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
jeremy.roy
Visitor
Visitor
4,483 Views
Registered: ‎11-02-2016

Hi @vijayak,

 

I am using Windows 10.  I tried installing Vivado2016.3 and was able to reproduce the error.  Running the following procedure from the tcl console in the GUI freezes Vivado:

proc freeze {} {
    stop_gui
    start_gui
}

Here is a more complete example of what I'm trying to do:

 

 

# Allow RTL modules in block-design
set_property source_mgmt_mode All [current_project

proc custom_synth {} {
  variable bd_dir
variable bd_file
variable active_block_design_name
variable outputDir # Generate HDL for block-design generate_target all [get_files $bd_file] make_wrapper -files [get_files $bd_file] -top read_verilog $bd_dir/hdl/${active_block_design_name}_wrapper.v set_property top ${active_block_design_name}_wrapper [current_fileset]
# Must stop gui to manually update compile order
stop_gui update_compile_order -fileset sources_1 # Synthesize design synth_design # Save design checkpoint with timestamp, write output reports set outputDir $outputDir/Synthesis/Synth_$datetime file mkdir $outputDir write_checkpoint -force $outputDir/post_synth report_timing_summary -file $outputDir/post_synth_timing_summary.rpt report_power -file $outputDir/post_synth_power.rpt # Open Vivado GUI
start_gui }

When I run custom_synth from Windows cmd, git_bash, or tclsh, everything performs smoothly.  If I run custom_synth from the tcl console in the Vivado GUI, the Vivado GUI freezes upon the next triggered tcl command (I can't even exit Vivado - I need to kill the process).  Now, I need to update the compile order between generating the block-design output products and running synthesis.  When I run update_compile_order from within the Vivado GUI, I get the following message:

INFO: [Vivado 12-3458] The update_compile_order command is not intended for use in the GUI, where 
compile order updates occur based on project changes and the hierarchy update settings. No update
performed.

Therefore, I resorted to closing the Vivado GUI before synthesis to run the update_compile_order tcl command.

 

Perhaps I am taking the wrong approach to solving this problem.  Thanks for your help,

 

Jeremy

 

0 Kudos
nupurs
Moderator
Moderator
7,967 Views
Registered: ‎06-24-2015

@jeremy.roy,

 

Can you run update_compile_order with the -force_gui option?

Refer page 1494 of this link for details: https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_3/ug835-vivado-tcl-commands.pdf

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).

View solution in original post

jeremy.roy
Visitor
Visitor
4,451 Views
Registered: ‎11-02-2016

Hi @nupurs,

 

That does solve my problem.  Thanks!

0 Kudos