UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
12,781 Views
Registered: ‎01-02-2008

Problem with Makefile and vivado

Hi, 

I have a project with Makefile, using vivado flow and targetting Kintex7.

The Makefile is written by someone else. 

 

When I try to "Make synth", it gives me this error:  

 

make -C ../microblaze netlist libs
make[1]: Entering directory `C:/JEFFL/Projects/vivadoproj/syn/microblaze'
make[1]: Nothing to be done for `netlist'.
make[1]: Nothing to be done for `libs'.
make[1]: Leaving directory `C:/JEFFL/Projects/vivadoproj/syn/microblaze'
#-------------------------------------------------------------------
#- Vivado Synthesis...
#-------------------------------------------------------------------
vivado -mode batch -source vivadoproj_synth.tcl -tclargs "XST" vivadoproj xc7k160t-fbg676-2 edkBmmFile.bmm _synth
WARNING: $XILINX contains multiple entries. Setting
$XIL_PA_NO_XILINX_OVERRIDE to 1.

WARNING: $XILINX_EDK contains multiple entries. Setting
$XIL_PA_NO_XILINX_EDK_OVERRIDE to 1.

WARNING: $XIL_PA_NO_XILINX_OVERRIDE is set to 1.
When $XIL_PA_NO_XILINX_OVERRIDE is enabled
$XILINX, $MYXILINX, $PATH, and $LD_LIBRARY_PATH must
be manually set.
WARNING: $XIL_PA_NO_XILINX_EDK_OVERRIDE is set to 1.
When $XIL_PA_NO_XILINX_EDK_OVERRIDE is enabled
$XILINX_EDK, $PATH, and $LD_LIBRARY_PATH must
be manually set.
WARNING: c:/Xilinx/SDK/2013.2/lib/lin does not exist.
WARNING: c:/Xilinx/SDK/2013.2/bin/lin does not exist.
ERROR: c:/Xilinx/Vivado/2013.2/tps/lnx32/jre does not exist.
Vivado is unable to locate a valid installation of JAVA. PlanAhead is necessary\n
for Vivado to run. Please contact customer support for assistance.

 

My environment is windows, i don't know why it's looking for linux directories. 

One more weird thing, If i run it from the command line, i.e just type 

vivado -mode batch -source vivadoproj_synth.tcl -tclargs "XST" vivadoproj xc7k160t-fbg676-2 edkBmmFile.bmm _synth

It runs through without any problem. 

 

Any ideas, suggestion?

Thanks, guys!

Jeff

0 Kudos
7 Replies
Xilinx Employee
Xilinx Employee
12,756 Views
Registered: ‎04-16-2012

Re: Problem with Makefile and vivado

Hi,

Check whether the $XILINX_EDK, $XILINX environmental variables are set. To check right-click on My Computer --> select Properties --> Click on Advance System Settings --> click on Enviornmental Variables (in Advanced Tab).

Also, where are you running this make file?

Thanks
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Teacher muzaffer
Teacher
12,750 Views
Registered: ‎03-31-2012

Re: Problem with Makefile and vivado

did you source your X:\Xilinx\Vivado\yyyy.xx\settings32.sh script before running make ?

- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
0 Kudos
Visitor binupr
Visitor
11,061 Views
Registered: ‎03-15-2010

Re: Problem with Makefile and vivado

I am having the same problem currently when I am trying to run XAPP1167. I manually set the Xilinx and Xilinx_EDK environment variables. Software version is Vivado 2014.4

0 Kudos
Participant fsanchezfernandez
Participant
9,831 Views
Registered: ‎09-11-2015

Re: Problem with Makefile and vivado

Hello, 

Did you find a solution?

0 Kudos
Adventurer
Adventurer
9,815 Views
Registered: ‎01-02-2008

Re: Problem with Makefile and vivado

I did, but I don't remember ... how there's something to do with linux/windows ... it's thinking it's in linux shell

 

0 Kudos
Highlighted
Adventurer
Adventurer
9,814 Views
Registered: ‎01-02-2008

Re: Problem with Makefile and vivado

I did, but I don't remember how ...  there's something to do with linux/windows ... it's thinking it's in linux shell

 

0 Kudos
681 Views
Registered: ‎05-28-2018

Re: Problem with Makefile and vivado

Chech your PATH environment variable, it should be looked like "c:/Xilinx/Vivado/2013.2/bin:XXXXX", so 'vivado' executable can be found by command line interface, then than command works fine; but it can't found by Makefile.

So set PATH like "/c/Xilinx/Vivada/2013.2/bin:XXXXX", then Makefile works fine.

I use mingw, and set PATH in $MIN_GW/msys/1.0/etc/profile.

 

 

0 Kudos