cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer
Observer
9,006 Views
Registered: ‎11-14-2014

write_project_tcl IP version issue

Jump to solution

Hi everybody,

 

I'm using Vivado 2014.4 on a Windows 7 64-bit machine and I'm trying to use write_project_tcl command to archive my project. I'm working in project-mode, so I export my build.tcl build file with:

 

File->Write Project Tcl

 

Then I put my build.tcl and all my "source_1" directory somewhere in my hard drive. I also edit the build.tcl file to suite the new location I chose. I changed:

 

- the "origin_dir",

- the "orig_proj_dir,

- the set_property "ip_repo_paths".

 

The modified file is attached.

 

When I try to rebuild my project sourcing build.tcl, everything seems to work fine. Block design and design wrapper files are correctly loaded. Xilinx proprietary IP are also correct but my own IP are not (the ones in the "ip_repo_paths"). If I run a report_ip_status they all result as "unsupported parts".

 

I noticed the source file list (# Set 'sources_1' fileset object) contains only .bd and .upgrade_log files. No .vhd or .v file are in the list.

 

Any suggestion to correctly rebuild the project?

 

Leoanrdo

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer
Observer
17,225 Views
Registered: ‎11-14-2014

Re: write_project_tcl IP version issue

Jump to solution

The problem with my own IPs was the board device and the target language were not automatically recognized in the new-built project. Once correctly set  in the General Settings tab all my IPs got unlocked.

 

Thank you,

 

Leonardo

View solution in original post

0 Kudos
5 Replies
Highlighted
Explorer
Explorer
8,998 Views
Registered: ‎04-28-2015

Re: write_project_tcl IP version issue

Jump to solution

Hi Leonardo,

Please see if the below AR applies to your issue:
http://www.xilinx.com/support/answers/59239.html 


Also, do check if the tool is providing any warnings while executing write_project_tcl command.

Regards,
Tushar.

 

 

0 Kudos
Highlighted
Scholar
Scholar
8,995 Views
Registered: ‎06-05-2013

Re: write_project_tcl IP version issue

Jump to solution

@leonardo_guidi How did you generate write_project_tcl? did you used -all_properties attribute? If not try it.

 

Regarding your custom IP, can you check the part of your project and IPs part

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Observer
Observer
8,983 Views
Registered: ‎11-14-2014

Re: write_project_tcl IP version issue

Jump to solution

I checked the answer record 59239. The issue #2 seems to be the same as mine, but the solution given resolves only #1.

 

Ok, yes I get some warnings:

 

write_project_tcl {D:/lavoro/lavoro_marco/vivado/build.tcl}
WARNING: [filemgmt 56-28] Property 'runtime' is deprecated. If running in batch mode, please update your script and use 'xsim.simulate.runtime' instead.
WARNING: [filemgmt 56-28] Property 'runtime' is deprecated. If running in batch mode, please update your script and use 'xsim.simulate.runtime' instead.
WARNING: [filemgmt 56-28] Property 'unit_under_test' is deprecated. If running in batch mode, please update your script and use 'xsim.simulate.uut' instead.
WARNING: [filemgmt 56-28] Property 'unit_under_test' is deprecated. If running in batch mode, please update your script and use 'xsim.simulate.uut' instead.
WARNING: [filemgmt 56-28] Property 'xelab.debug_level' is deprecated. If running in batch mode, please update your script and use 'xsim.elaborate.debug_level' instead.
WARNING: [filemgmt 56-28] Property 'xelab.debug_level' is deprecated. If running in batch mode, please update your script and use 'xsim.elaborate.debug_level' instead.
WARNING: [filemgmt 56-28] Property 'xelab.load_glbl' is deprecated. If running in batch mode, please update your script and use 'xsim.elaborate.load_glbl' instead.
WARNING: [filemgmt 56-28] Property 'xelab.load_glbl' is deprecated. If running in batch mode, please update your script and use 'xsim.elaborate.load_glbl' instead.
WARNING: [filemgmt 56-28] Property 'xelab.more_options' is deprecated. If running in batch mode, please update your script and use 'xsim.elaborate.xelab.more_options' instead.
WARNING: [filemgmt 56-28] Property 'xelab.more_options' is deprecated. If running in batch mode, please update your script and use 'xsim.elaborate.xelab.more_options' instead.
INFO: [Common 17-14] Message 'filemgmt 56-28' appears 100 times and further instances of the messages will be disabled. Use the Tcl command set_msg_config to change the current settings.
INFO: [Vivado-projutils-8] Tcl script generated (D:/lavoro/lavoro_marco/vivado/build.tcl)

WARNING: [Vivado-projutils-10] Found source(s) that were local or imported into the project. If this project is being source then please ensure that the project source(s) are also part of this source controlled data. The list of these local source(s) can be found in the generated script under the header section.

 

 

 

Leonardo

0 Kudos
Highlighted
Observer
Observer
17,226 Views
Registered: ‎11-14-2014

Re: write_project_tcl IP version issue

Jump to solution

The problem with my own IPs was the board device and the target language were not automatically recognized in the new-built project. Once correctly set  in the General Settings tab all my IPs got unlocked.

 

Thank you,

 

Leonardo

View solution in original post

0 Kudos
Highlighted
Explorer
Explorer
8,948 Views
Registered: ‎04-28-2015

Re: write_project_tcl IP version issue

Jump to solution

Hi Leonardo,

 

It is good to know that your issue is resolved.
Please mark your post as 'Accept as Solution' so that it will help others facing similar issue.

 

Regards,
Tushar.

0 Kudos