cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
@sidda123
Observer
Observer
8,384 Views
Registered: ‎01-19-2016

How to reduce router runtime in vivado....???

Jump to solution

Hi, 

  I have built my design using Vivado 2016.1 with AXI BUS interface. 

I have used 2 BRAM Controllers, 1 Microblaze Processor. The design is successfully synthesized. 

 

But the Vivado tool is not comming out of ROUTING process. 

 

Can anybody help us to come out of routing Process . Below i have attached Warning message Screenshot.

Screenshot_44.png
0 Kudos
1 Solution

Accepted Solutions
syedz
Moderator
Moderator
15,323 Views
Registered: ‎01-16-2013

@sidda123,

 

To enable the flag you should actually be using the below TCL command in the Vivado TCL console:

set_param route.enableHoldExpnBailout 1

 

--Syed

 

 

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------

View solution in original post

5 Replies
vuppala
Xilinx Employee
Xilinx Employee
8,381 Views
Registered: ‎04-16-2012

Hi @sidda123

 

As warning specified, did you try by turning on the flag route.enableHoldExpnBailout?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
@sidda123
Observer
Observer
8,379 Views
Registered: ‎01-19-2016
Hi @vuppala

I searched for that option ("route.enableHoldExpnBailout") , but i didn't get it.

Can you please help us to find that flag option. where can i get it...???
0 Kudos
nupurs
Moderator
Moderator
8,372 Views
Registered: ‎06-24-2015

Hi @sidda123,

 

Type this in tcl console:
set_param route.enableHoldExpnBailout 0

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).
0 Kudos
syedz
Moderator
Moderator
15,324 Views
Registered: ‎01-16-2013

@sidda123,

 

To enable the flag you should actually be using the below TCL command in the Vivado TCL console:

set_param route.enableHoldExpnBailout 1

 

--Syed

 

 

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------

View solution in original post

jcmoctezuma
Observer
Observer
5,252 Views
Registered: ‎08-14-2007

Hi,

 

Where can I get information or the complete list about the parameters I can use and their meaning, for example "enableHoldExpnBailout" parameter, which document comes that information?

 

Thanks

JC

0 Kudos