UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor hassan.anwar
Visitor
1,771 Views
Registered: ‎04-17-2014

Readback for Artix by using Impact on Linux

I am doing the readback using impact on LINUX. I am using the Artix-7. I successfully program the FPGA with the impact

 

setmode -bscan
setcable -p auto
addDevice -p 1 -file adder_dut.bit
program -p 1
quit

 

impact -batch program.sh

 

But when I do the readback the readback.sh code is :

 

setmode -bscan
setcable -p auto
addDevice -p 1 -file adder_dut.bit
verify -p 1
quit

 

 

It asks for the mask file that I have ignored the by setting in my bash file:

 


export XIL_IMPACT_VIRTEX_DUMPBIN=1export

export XIL_IMPACT_IGNORE_MASK_FILE=1

 

But it didn't work any idea how to do it in Linux.

0 Kudos