cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
renesond
Visitor
Visitor
1,634 Views
Registered: ‎02-01-2012

UG871 Using HLS IP in a Zynq

Jump to solution

Hello

 

following tutorial lab1 in UG871 (page 211 etc.), I end up with a system that crashes when it tries to send the data to the PL. Up to the crash, there were no errors. Anything that is sent to the console shows up on the console up to XHls_macc_WriteRegister().  It ends with the message "Progarm to test communication with HLS MACC block in PL" (page 236). I don't know where to start looking for the problem.

 

My environment is:

Windows 7, Vivado 2014.3.1, with MicroZed board.

 

Since my hardware is different to the tutorial, I did the following:

Started HLS, created project with MicroZed board, copied hls_macc files from the tutorial, ran simulation and synthesis, exported IP, started Vivado, created project with MicroZed board, and followed the rest of the tutorial.

 

Would you have any suggestion how to make this work?

 

Kind regards,

Rene

0 Kudos
1 Solution

Accepted Solutions
renesond
Visitor
Visitor
2,069 Views
Registered: ‎02-01-2012

Hello

 

I found my mistake. I missed step 7 (page 229) and didn't program the FPGA. With this step, the tutorial lab1 works :)

 

Kind regards,

Rene

View solution in original post

Tags (1)
0 Kudos
1 Reply
renesond
Visitor
Visitor
2,070 Views
Registered: ‎02-01-2012

Hello

 

I found my mistake. I missed step 7 (page 229) and didn't program the FPGA. With this step, the tutorial lab1 works :)

 

Kind regards,

Rene

View solution in original post

Tags (1)
0 Kudos