cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Participant
Participant
894 Views
Registered: ‎07-22-2018

Error programming flash for qspi boot on ZCU102 Rev 1.1

Jump to solution

I have a ZCU102 Rev 1.1 board and am following UG1209 embedded design tutorial.

I was successfully able to get up to the section titled "Running the Image in QSPI Boot Mode on ZCU102 Board" (in Chapter 5). When I try to program the flash I get:

****** Xilinx Program Flash
****** Program Flash v2018.3 (64-bit)
  **** SW Build 2405991 on Thu Dec  6 23:38:27 MST 2018
    ** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.


Connected to hw_server @ TCP:127.0.0.1:3121
Available targets and devices:
Target 0 : jsn-JTAG-SMT2NC-210308A7A2D1
	Device 0: jsn-JTAG-SMT2NC-210308A7A2D1-24738093-0

Retrieving Flash info...

Initialization done, programming the memory
===== mrd->addr=0xFF5E0204, data=0x00000000 =====
BOOT_MODE REG = 0x0000
Downloading FSBL...
Running FSBL...
Finished running FSBL.
Problem in running uboot
Flash programming initialization failed.

ERROR: Flash Operation Failed

The bif file I used for BOOT.bin is:

//arch = zynqmp; split = false; format = BIN
the_ROM_image:
{
	[fsbl_config]a53_x64
	[bootloader]G:\zcu102\edt_zcu102\edt_zcu102.sdk\fsbl_a53\Debug\fsbl_a53.elf
	[destination_cpu = pmu]G:\zcu102\edt_zcu102\edt_zcu102.sdk\pmu_fw\Debug\pmu_fw.elf
	[destination_cpu = a53-0, exception_level = el-3, trustzone]G:\zcu102\ug1209-embedded-design-tutorial\qspi_boot\bl31.elf
	[destination_cpu = a53-0]G:\zcu102\edt_zcu102\edt_zcu102.sdk\testapp_r5\Debug\testapp_r5.elf
	[destination_cpu = a53-0, exception_level = el-2]E:\RHShared\qspi_boot\u-boot.elf
	[offset = 0x1E40000, destination_cpu = a53-0]E:\RHShared\qspi_boot\image.ub
}

When I am trying to program the flash, the SDK tries to switch to debug perspective with continuously showing the error:

Memory read error at 0x0. Cannot read 'sctlr_el3'. Cannot read 'r0'. Instruction transfer timeout.

I am new to Xilinx and any/all help is greatly appreciated.

Thank you
Subu

image.png

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Participant
Participant
811 Views
Registered: ‎07-22-2018

I used 2019.1 and was successfully able to complete booting from the flash.

 

View solution in original post

3 Replies
Highlighted
Xilinx Employee
Xilinx Employee
849 Views
Registered: ‎06-21-2018

Hi subu,

Take a look at these ARs:

https://www.xilinx.com/support/answers/71961.html

https://www.xilinx.com/support/answers/72210.html

Do you have a -05 ZCU102?

If that's the case, the solution would be to regenerate the FSBL with SDK 2018.3.

Thanks,
Andres

0 Kudos
Highlighted
Participant
Participant
837 Views
Registered: ‎07-22-2018

My board version is: 0432055-04-1842 (whizzysystems.com).

The HW revision is Z1-ZCU102 Rev 1.1

I have just installed 2019.1 and will try with that.

Thank you

Subu

0 Kudos
Highlighted
Participant
Participant
812 Views
Registered: ‎07-22-2018

I used 2019.1 and was successfully able to complete booting from the flash.

 

View solution in original post