UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie scapistros
Newbie
5,511 Views
Registered: ‎03-20-2012

Platform Cable USB II, installation

Hello.

 

I have the Platform Cable USB II, model DLC10, but I'm unable to install it.

 

I have installed two versions of the ISE, 10.1.03 and 12.2 (in Windows XP Profesional- Service Pack 2. I'm the administrator of this machine)
The enviroment variable is set to - XILINX c:\XILINX\10.1\ISE;
- Path: %XILINX%\bin\nt
I've followed the instructions in UG344, for 10.1 or later the driver for DLC10 is supposed to be installed, but it doesn't work.
I connect the Platform Cable USB II to the USB and follow the 'Found New Hardware wizard', but when it says 'This wizard helps you to install software for:' it shows 'USB Device' instead 'Xilinx Platform Cable USB Firmware Loader',
and then it doesn't find the necessary software ( I've tried to do it automatically and selecting a specific location)

 

Then I've followed the Step5 of document UG344, extracting the install_xusb.bat and xusbdrvr.inf in that directory (c:\XILINX\10.1\ISE\bin\nt). When I run the install_xusb.bat the final result is : install:completed successfully. But when I connect the cable again, the 'Found New Hardware wizard' doesn't find the driver.

 

Can anyone help me?

 

Regards

Sandra

 

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
5,504 Views
Registered: ‎12-17-2007

Re: Platform Cable USB II, installation

Instead of running the batch script, try opening a Windows command prompt window by itself (if on Windows Vista or Windows 7 be sure to choose "run as administrator"), then change directories to the Xilinx installation directory (in your case, choose the 12.2 location).

 

From there, go to $XILINX\bin\nt(64) depending on whether or not you have a 64-bit machine or a 32-bit machine.  From there, run "install_drivers.exe" directly.  Note that this must be done with the USB programming cable unplugged.  This will run a few commands and may take a few minutes to complete.

 

When it's done, plug your cable back in (preferably to a _different_ USB port) and let Windows re-detect the device and install the drivers.

 

A special note here is that if you have 64-bit Windows, you _must_ use the 64-bit iMPACT tool for programming.

-------------------------------------------
this space intentionally left blank
0 Kudos