UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
227 Views
Registered: ‎12-03-2019

SP701 evaluation kit - board_part definition was not found for xilinx.com:sp701:par0:1.0

Jump to solution

Hi,

Installed Vivado 2018.3.

Opened the project rdf0503-sp701-ipi-c-2018-3\sp701_ipi\sp701_ipi.xpr and get the following error.

I've ran the tcl command get_board_parts and can confirm that xilinx.com:sp701:part0:1.0 is missing.

How do I add the board_part definition?

Thanks for your help.

fpga_board_part_not_found.PNG

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
178 Views
Registered: ‎02-14-2014

Re: SP701 evaluation kit - board_part definition was not found for xilinx.com:sp701:par0:1.0

Jump to solution

Hi @ziltoid_the_omniscient ,

Yes this is the correct procedure to follow.

All recent boards for which you don't find board files in installation repository, you ought to download them from github and place them at same repository.

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

4 Replies
209 Views
Registered: ‎12-03-2019

Re: SP701 evaluation kit - board_part definition was not found for xilinx.com:sp701:par0:1.0

Jump to solution

I can see they are missing from the vivado board_files directory.

sp701_missing_from_board_files.PNG

 

0 Kudos
203 Views
Registered: ‎12-03-2019

Re: SP701 evaluation kit - board_part definition was not found for xilinx.com:sp701:par0:1.0

Jump to solution

I copied the files from the github and it compiled. Is this the usual procedure to follow?

https://github.com/Xilinx/XilinxBoardStore/tree/master/boards/Xilinx/sp701/1.0

0 Kudos
Xilinx Employee
Xilinx Employee
179 Views
Registered: ‎02-14-2014

Re: SP701 evaluation kit - board_part definition was not found for xilinx.com:sp701:par0:1.0

Jump to solution

Hi @ziltoid_the_omniscient ,

Yes this is the correct procedure to follow.

All recent boards for which you don't find board files in installation repository, you ought to download them from github and place them at same repository.

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

158 Views
Registered: ‎12-03-2019

Re: SP701 evaluation kit - board_part definition was not found for xilinx.com:sp701:par0:1.0

Jump to solution
Thank you @ashishd
0 Kudos