cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
1,116 Views
Registered: ‎02-22-2018

Unable to create a bootable boot.bin for a generated bit file in SD-Card mode ZCU102 in 2017.4 toolset Windows

Hi,

 

I am working on the Zynq Ultrascale+ MPSoc, ZCU102 Revision 1.1.

 

I have copied the pre-built images into the SD-Card and ran it on the board. The board boots fine with the pre-built images.

 

Now, I have written an FPGA code for which a bit file is also created.

 

I have used the http://www.wiki.xilinx.com/ZCU102+Image+creation+in+OSL+flow 

link to find the order for the files to be added for boot image creation in Xilinx SDK 2017.4(in Windows).

order I followed is:

fsbl

bit file

pmufw_image

bl31

u-boot.elf

 

Except for the bit file, I have used the other set of pre-built images from "2017.1-zcu102-release.tar.xz" section of http://www.wiki.xilinx.com/Zynq+2017.1+Release link.

 

After creating the boot image and copying it onto SD-Card, the board is not booting.

Below is what I am observing in the terminal:

øXilinx Zynq MP First Stage Boot Loader
Release 2017.4 Feb 22 2018 - 17:30:28
XPFW: Calling ROM PWRUP Handler..Done
XPFW: Calling ROM Isolation Handler..Done

 

On the board,I am able to observe INIT_B LED and PS_ERR_OUT LED glowing "RED".

 

Can I know where where I am wrong with Boot Image creation?

or If the procedure is wrong, can you point me in the proper direction?

0 Kudos
2 Replies
Highlighted
Scholar
Scholar
1,092 Views
Registered: ‎02-27-2008

Re: Unable to create a bootable boot.bin for a generated bit file in SD-Card mode ZCU102 in 2017.4 toolset Windows

All tools and images must use (be generated from 2017.4),

 

You cannot mix & match.


Tools must be consistent.

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Visitor
Visitor
1,045 Views
Registered: ‎02-22-2018

Re: Unable to create a bootable boot.bin for a generated bit file in SD-Card mode ZCU102 in 2017.4 toolset Windows

Hi,

 

    Thank you for the response.

I have followed all the steps from 

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_4/ug1209-embedded-design-tutorial.pdf

link.

 

The issue I had was with the security firmware file.

I started using the one from the above link and the board started to boot.