UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor rgeorge
Visitor
235 Views
Registered: ‎01-15-2020

ZC706 BIST test fails to connect

Hello,

I am using ZC706 board(brand new, just out of the box). I have installed all the required software and the Switch positions are correct.I have gone through the comments given in this portal and checked the configurations, all seems to be correct.

SW4: 01(digilant), sw11 : 00010 ( Boot fromQSPI), Installed the 2015.4 version of XILINX SDK and Vivado

but when I am using the command prompt, to run the BIST test , i am getting the following errors.

C:\zc706_bist\ready_for_download>call C:\Xilinx\SDK\2015.4\bin\xmd.bat -tcl download_bit.tcl system_wrapper.bit

****** Xilinx Microprocessor Debugger (XMD) Engine
****** XMD v2015.4 (64-bit)
**** SW Build 1412921 on Wed Nov 18 09:43:45 MST 2015
** Copyright 1986-2015 Xilinx, Inc. All Rights Reserved.

Executing user script : download_elf.tcl

JTAG chain configuration
--------------------------------------------------
Device ID Code      IR Length Part Name
1          23731093     6              xc7z045
Error Executing User Script : download_elf.tcl
Error :: ERROR:
Could not find a ARM device on the board. Please check if the target is in:
1. Split JTAG mode - No operations are possible with ARM DAP
2. Non Jtag bootmode - Bootrom may need time to enable DAP. Please try again

I am using the Window10 environment and the device driver for usb looks ok

USB-Driver.pngCan someone help me to resolve this issue on  ZC706 board ?

USB-Driver.png
0 Kudos
4 Replies
Moderator
Moderator
156 Views
Registered: ‎04-12-2017

Re: ZC706 BIST test fails to connect

Hello @rgeorge 

Try following steps:

1. First uninstall exisitng version of silabs drivers from your windows 10 machine.

2. Install v6.7 of USB to UART drivers.

3. Restart the machine.

4. Try the BIST design again.

Above steps should help fix your issue.

Regards

Kunal

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Moderator
Moderator
102 Views
Registered: ‎06-14-2010

Re: ZC706 BIST test fails to connect

Hello @rgeorge ,

This topic is still open and is waiting for you.

If your issue is not solved yet, please reply in the thread, so that we can assist you with your issue.

However, if your question is answered and/or your issue is solved, please mark the response that resolved your issue, as Accepted Solution (more info on this can be found here: https://forums.xilinx.com/t5/help/faqpage/faq-category-id/solutions#solutions). This way, the topic can be completed then.  We appreciate your help.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor rgeorge
Visitor
95 Views
Registered: ‎01-15-2020

Re: ZC706 BIST test fails to connect

I am able to connect now.
Readsons for not connecting
1. USB driver in windows
2. SD card shipped with the board was corrupted(Not readable, boot sector fault). Need to rebuild the image in another SD card.
Regards,
Regi
Moderator
Moderator
24 Views
Registered: ‎04-12-2017

Re: ZC706 BIST test fails to connect

@rgeorge 

Can you mark the appropriate post as accepted solution to help the community?

Regards

Kunal

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos