UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor rockyz
Visitor
2,453 Views
Registered: ‎10-23-2013

ZC706 base board recognize issue with Bi-OS

Hi everyone,

 

could you please give me a hand?

 

There is one ZC706 base board including the XC7Z045-2FFG900 C SoC in my hand.

And my computer is Bi-OS (windows and fedora).

When I power on my board under windows, there is unknow PCI device listed under Device Manager, and LED on board can light. Everything seems normal.

Then I switch into fedora, my PC cannot recognize the device and LED delights as well.

Then as you imaged, I switch OS into Windows again, there is no any unknow PCI device under Device Manager. So, I restart my board, unfortunately, Windows cannot recognize the device.

 How could this be?

 I am curious that is it necessary to recognize the device without driver under fedora?

 How can I solve this problem?

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
2,444 Views
Registered: ‎08-01-2008

Re: ZC706 base board recognize issue with Bi-OS

check these debug ARs
https://www.xilinx.com/support/answers/54013.html
https://www.xilinx.com/support/answers/54134.html
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
2,415 Views
Registered: ‎03-20-2017

Re: ZC706 base board recognize issue with Bi-OS

I tried PCIe debug steps of debug ARs in xtp246.pdf from your suggestion, but there was not the pcie device information show like Page42 when I went through the tutorial. How can I solve this problem?
Thanks and Regards
0 Kudos
2,413 Views
Registered: ‎03-20-2017

Re: ZC706 base board recognize issue with Bi-OS

should be

1.png

but my result is

pcitreeshow.png

no pcie device was detected

2.png

How can I solve this problem?

0 Kudos