UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer jorsong
Observer
8,552 Views
Registered: ‎06-04-2009

video capture exmaple does not work

Jump to solution

I ran the video capture example on XUP V2 board with vdec 1 daughter board

 

i'am using edk 9.1i everything's going well..I successfully complied the project and got the echo from rs232 port like release not documents shows

 

but when I connect board to monitor and a video camera .the monitor shows nothings...

 

who can help me,does anyone meets the same thing?

 

 oh, the monitor's a common computer monitor ,and the source camera's output is PAL.I am sure all the facilites works well..

 

 

well  I find some datasheets tells me, the board takes in pal resouces result this ....and who can tell me how to config vdec1 daughter board as PAL through iic bus????

thanks a lot!

Message Edited by jorsong on 06-16-2009 04:30 AM
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer jorsong
Observer
10,198 Views
Registered: ‎06-04-2009

Re: video capture exmaple does not work

Jump to solution

well ,No one reply me??????

 

 

hmm.....Finally I solved the problem

 

Have to rewrite a part of ipcore codes to make reference design's can output PAL DACs correctly....

 

NO necessary to configure  vdec1 daughter board ,it's adaptive to take PAL or NTSC format if you set 0x00 register  the value 0x00 as RD do....

Message Edited by jorsong on 06-17-2009 09:53 AM
Message Edited by jorsong on 06-17-2009 09:54 AM
Tags (1)
0 Kudos
7 Replies
Highlighted
Observer jorsong
Observer
10,199 Views
Registered: ‎06-04-2009

Re: video capture exmaple does not work

Jump to solution

well ,No one reply me??????

 

 

hmm.....Finally I solved the problem

 

Have to rewrite a part of ipcore codes to make reference design's can output PAL DACs correctly....

 

NO necessary to configure  vdec1 daughter board ,it's adaptive to take PAL or NTSC format if you set 0x00 register  the value 0x00 as RD do....

Message Edited by jorsong on 06-17-2009 09:53 AM
Message Edited by jorsong on 06-17-2009 09:54 AM
Tags (1)
0 Kudos
Newbie hgunay
Newbie
8,400 Views
Registered: ‎07-02-2009

Re: video capture exmaple does not work

Jump to solution

I am trying to run the video capture example with edk 9.1 but opb iic license error occurs. How did you solve the license problem? If you can answer asap, I would be glad.

 

Thanks.

0 Kudos
Visitor ravi12
Visitor
8,271 Views
Registered: ‎07-12-2009

Re: video capture exmaple does not work

Jump to solution

hi jorsong,

 

 

 

I have the XUP V2 board and digilent  vdec daughter card.

 

I want to connect board to monitor and a video camera and the camera output is PAL.

 

i don't know how to  config vdec daughter card through iic bus. i have tried but i fail.

 

u have already solved this problem.  please tell me what modifications i have to do in

 

in ipcore codes and how to set the register values. If you can answer asap, I would be glad.

 

 

Thanks

 

my mail id is ravi01_2000@yahoo.com

0 Kudos
Observer jorsong
Observer
8,263 Views
Registered: ‎06-04-2009

Re: video capture exmaple does not work

Jump to solution
 
 
I guess you've already downloaded the reference design of video capture for V2P....the rd got a C program to configure vdec1 daughter board through iic bus ,it's configuration is adaptive ,the daughter board can automatically detects if  input is NTSC or PAL. So,just use rd's configuration,it's ok.
 
IP core's edit's necessary.....you can read comment lines in HDL code...it's of  great help.....it only need to edit little parts of the codes...you can turn to itu 601/656 for help ,note the difference between PAL and NTSC...such as PAL has 625 lines each frame while NTSC only got 525...
 
0 Kudos
Observer voroshazi
Observer
7,169 Views
Registered: ‎10-10-2008

Re: video capture exmaple does not work

Jump to solution

 I had got the same problem but in EDK 10.1 SP3.

It is a simple trick:

change the actual date in your OS system back to 2007 (when edk 9.1 was released).

 

cheers,

 

 Zsolti

0 Kudos
Visitor munis
Visitor
7,024 Views
Registered: ‎10-27-2009

Re: video capture exmaple does not work

Jump to solution

Jorsong please can you tell me which exact part of HDL code that i have to edit . Also please tell me what can i do for OPB iic license issue!

 

Thanks in advance

0 Kudos
Observer voroshazi
Observer
6,961 Views
Registered: ‎10-10-2008

Re: video capture exmaple does not work

Jump to solution

dear munis,

 

you have two alternatives

- if you want to use the old, licensed opb_i2c IP core, you can simply "change the actual date in your OS back to 2007 or 2008 (when edk 9.1 - 10.1 was released)".

 

- secoundly, if you do not want to do this change you should build a new edk project without opb_bus and opb based ip cores. The xps_i2c ip core works with vdec-1 board in all video input format.

for details see this:

http://forums.xilinx.com/xlnx/board/crawl_message?board.id=EMBEDDED&message.id=1084

 

cheers,

 

 Zsolti

 

 

 

 Zsolti

 

0 Kudos