cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
arajender
Visitor
Visitor
8,756 Views
Registered: ‎04-18-2013

BRAM reading and writing issues in virtex 4 nallatech kit

Hi,

        i am using virtex 4 and BRAM from Nalltech kit .....

         i am writing data of an array of 8x512 values of 32 bit unsigned integer ,i am not able to read some specific value from a location like last 50 elements of  first array (data[0][512])  are read as garbage values and first 20 elements of 2nd array (data[1][512]) are also the same and the rest  of the data is read fine ....

 

   please can any one help me with this problem .....Thanks in advance....

0 Kudos
2 Replies
vsrunga
Xilinx Employee
Xilinx Employee
8,743 Views
Registered: ‎07-11-2011

Hi,

 

Is this in simulation or hardware?

Can you share your memory accessing logic/testcase/waveform shanpshots so that we may give any clues?

 

 

Regards,

Vanitha.

 

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented
0 Kudos
balkris
Xilinx Employee
Xilinx Employee
8,728 Views
Registered: ‎08-01-2008

You can try with fixed primitve option during core generation.

 

What is your configuration minimum area, low power, fixed primitive.

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos