cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
349 Views
Registered: ‎02-07-2019

CPRI IP core upgrade fails

Hi there

While updating our project from vivado 2017.2 to 2019.2 following error occures with the CPRI IP core.

Vivado suggests to update our core from 8.7 to 8.11 which fails with following error message:

[IP_Flow 19-3477] Update of parameter 'PARAM_VALUE.HARD_FEC_WRAPPER' failed for IP 'cpri_0'. can't read "has_supported_architecture": no such variable

Due to that I tried to delete all instances of the ip core from the project and re customize a new core, however this fails already when I try to customize the cpri core in the IP catalog.

Any ideas or suggestions?

Tags (4)
0 Kudos
2 Replies
Highlighted
Newbie
Newbie
269 Views
Registered: ‎07-12-2019

Re: CPRI IP core upgrade fails

I've had the same problem. Creating even a new project in 2019.2 with CPRI IP (for Zynq 7000 series) has the same problem.

0 Kudos
Highlighted
Visitor
Visitor
168 Views
Registered: ‎10-09-2017

Re: CPRI IP core upgrade fails

Hi

I used the Zynq Series from vivado 2019.2.

I had same issue about cpri core update error and found the solution.

This case operate only vitis IDE version.

I think that you installed only vivado.

If you enter the C:\Xilinx\.xinstall\Vivado_2019.2\xuninstall.exe, you can select the update vitis.

After update, check the create about cpri core.

Thanks.

 

 

0 Kudos