cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
442 Views
Registered: ‎12-10-2019

Fatal Error xil_printf.h,xil_types.h and xparameters.h not found error in vitis software

Jump to solution

we are getting the Xilinx library files (xil_printf.h,xil_types.h and Xparameters.h) in the Vitis software build. we are validating the JESD204B IP. We have created the MicroBlaze project for configuring the AD device. when we build the project we are getting all the Xilinx library header files not found errors.

0 Kudos
Reply
1 Solution

Accepted Solutions
Adventurer
Adventurer
339 Views
Registered: ‎03-13-2019

Hello @swathi

I think vitis 2020.1 is having some issues in Windows system.

Out of many reasons for this issue one potential issue could be the workspace path.

If it is too long these errors might appear. (Max 250 characters in Windows I guess)

Check the path once it may help.

You can also try what @adem369 mentioned.

Regards
Pavan
==========================================
Accept as solution if it resolves your issue. Give kudos if it is helpful 

View solution in original post

0 Kudos
Reply
2 Replies
Contributor
Contributor
375 Views
Registered: ‎02-18-2019

It is a bug of Vitis/SDK, try Re-generate BSP Sources or create new project.

0 Kudos
Reply
Adventurer
Adventurer
340 Views
Registered: ‎03-13-2019

Hello @swathi

I think vitis 2020.1 is having some issues in Windows system.

Out of many reasons for this issue one potential issue could be the workspace path.

If it is too long these errors might appear. (Max 250 characters in Windows I guess)

Check the path once it may help.

You can also try what @adem369 mentioned.

Regards
Pavan
==========================================
Accept as solution if it resolves your issue. Give kudos if it is helpful 

View solution in original post

0 Kudos
Reply