UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

PS7_CAN_0 missing when migrating XAPP794 to ZC706

Adventurer
Posts: 74
Registered: ‎03-27-2014

PS7_CAN_0 missing when migrating XAPP794 to ZC706

Hello all,

 

We are trying to implement the 794 appnote on ZC706 instead of the ZC702. The changes we made were:

 

- part number in scripts/build.tcl

- constraints in constr/top_orig.xdc

- i2c net name in srcs/hdl/design_1_wrapper.v

 

The design compiled and synthesized fine in Vivado 2013.2. Bitstream was generated etc. I exported the design to HW and tried to build the FSBL but not successful. The "fsbl_bsp" libgen fails because the system.mss couldn't parse the XML file for ps7_can_0. I went back to Vivado and in the IP Integrator saw that the PS does not have CAN0 enabled. Question:

 

1. Why did the CAN get disabled? I didn't change anything related to CAN0. Does Vivado have some database about Zynq parts to figure out that 7z045 should have CAN turned off and 7z020 should have it on?

 

2. Vivado wouldn't let me make any changes. None of the checkboxes can be toggled as if the entire PS design is read-only. I am at my wit's end right now. How can it be so? 

 

Any tips greatly appreciated. Thanks.

Xilinx Employee
Posts: 1,128
Registered: ‎07-01-2010

Re: PS7_CAN_0 missing when migrating XAPP794 to ZC706

Hi,

I dont think vivado enable the peripherial CAN based on the zynq device selection as the peripherials are fixed across zynq device. it may be based on the tcl sourced to create the Project.Have you chnaged the device part other than the device specified in the XAPP? Let me know so that i can re-check.

Can you select the zynq IP in block design and try to change the configuration through the properties window?

Regards,
Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
Adventurer
Posts: 74
Registered: ‎03-27-2014

Re: PS7_CAN_0 missing when migrating XAPP794 to ZC706

Thanks Achutha,

 

I modified only the build_camera_design.tcl script to make the part as xc7z045ffg900-1 and the board as xilinx.com:zynq:zc706:1.1. No other part changes.

 

I did try to select the Zynq IP block and modify the properties. But the Vivado tool wouldn't let me modify the configuration properties. Strange but I can't get it to change.

 

Separately, I built another project without making any changes from the appnote files. Tried to build it for ZC702 and this went through fine. Then I selected the Zynq in this project and even here I couldn't modify any checkboxes for the PS. As if everything is read-only.

 

Thanks for your help.

Highlighted
Visitor
Posts: 6
Registered: ‎06-09-2014

Re: PS7_CAN_0 missing when migrating XAPP794 to ZC706

Hello, agaurav!

I'm also porting appnote 794 to zc706. Could you manage this?

Now I am analyzing a port compatatibility between LPC on zc702 and zc706 to make a proper port mapping.

Also, I didn't yet understand how i2c net names should be changed in "srcs/hdl/design_1_wrapper.v".

If possible - can you share your "top_orig.xdc" and "design_1_wrapper.v".

Xilinx Employee
Posts: 1,128
Registered: ‎07-01-2010

Re: PS7_CAN_0 missing when migrating XAPP794 to ZC706

[ Edited ]

Gaurav Wrote:-

Thanks Achutha,

 

I modified only the build_camera_design.tcl script to make the part as xc7z045ffg900-1 and the board as xilinx.com:zynq:zc706:1.1. No other part changes.

 

I did try to select the Zynq IP block and modify the properties. But the Vivado tool wouldn't let me modify the configuration properties. Strange but I can't get it to change.

 

Separately, I built another project without making any changes from the appnote files. Tried to build it for ZC702 and this went through fine. Then I selected the Zynq in this project and even here I couldn't modify any checkboxes for the PS. As if everything is read-only.

 

Thanks for your help.

 

##########################################################


Can you try report IP status option after opening the block design to see if Zynq IP is update and is not locked?

Regards,
Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
Xilinx Employee
Posts: 1,128
Registered: ‎07-01-2010

Re: PS7_CAN_0 missing when migrating XAPP794 to ZC706

Hi ,

Is this issue resolved?

Regards,
Achutha
---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------