UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

Highlighted
Newbie
Posts: 6
Registered: ‎08-11-2017

Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

Hi,

We got recently the Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit and I have been unable to get the serial connection working.

Can anybody please shed some light (steps) on to how to connect via serial to this board?

Thank you!
Victor.

Voyager
Posts: 719
Registered: ‎06-24-2013

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

Hey @inviktor,

 

Maybe this wiki entry helps?

 

All the best,

Herbert

-------------- Yes, I do this for fun!
Explorer
Posts: 122
Registered: ‎04-13-2015

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

The ZCU102 UART-USB connector is tied to a Silicon Lab QUAD chip:

      4 UARTs can go through the USB

I am using UART PS device #0 (same one as on the supplied MMC) and it is on the 2nd bridge of the Silicon Lab.

In Teraterm / Windows the 4 bridges are shown in the "port" pull-down menu.

 

Hoping this helps,

Regards

 

 

Explorer
Posts: 122
Registered: ‎04-13-2015

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

Just checked it....

Bad memory, it's the 3rd one

 

Regards

Voyager
Posts: 526
Registered: ‎03-22-2016

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

@ericv I always go to Windows/Control Panel/System/Device Manager

They are always in order there

 


* Henry Bucher, Baremetal Labs, Extreme Financial Engineering: btlabs.us
zcuusb.PNG
Explorer
Posts: 122
Registered: ‎04-13-2015

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

@hbucher

 

Yes, I should have done gone through all the "necessful"   :-)

 

Regards

Newbie
Posts: 6
Registered: ‎08-11-2017

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

Hi Everyone,

Thanks a lot for all the responses. Unfortunately, I am still blocked. I cannot get any output from the board.

I tried all the HDMI and Display ports, and I get nothing. I tried all mini-USB, and nothing. I see the LED DS47 (sysctrl) flashing with green light, on and off. Does anybody know of this is expected?

Also, my host machine is a Ubuntu 14.04, so I downloaded the driver for it, from here, from the twiki hpoetzl suggested, and I get a lot of "no such file or directory" errors for header files.

I don't know what else to do.

Thanks a lot!

Newbie
Posts: 6
Registered: ‎08-11-2017

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

This is one error I get when I try to compile the driver:

{local@serialc:52} make cp210x
cc cp210x.c -o cp210x
cp210x.c:18:24: fatal error: linux/slab.h: No such file or directory
#include <linux/slab.h>
^
compilation terminated.
make: *** [cp210x] Error 1

Newbie
Posts: 6
Registered: ‎08-11-2017

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

Another problem I have with the board is the lack of documentation on how to properly set the switches.  I followed the BIST setup to double-check the board is configured properly, but now every time I reset the board it tries to do the test again, which need physical pushing of bottoms, which is not desirable.

 

Does anybody know what is the default position for the pins of all the switches on this board? The documentation Board User Guide could not be more complicated to read, and I see no clear explanation of this.

Thanks!

Newbie
Posts: 6
Registered: ‎08-11-2017

Re: Serial connection not working on Xilinx Zynq UltraScale+ MPSoC ZCU102 Evaluation Kit

Ok, I found the Switch defaults now, although it still doesn't work.